Carlinkit is not connecting

I have done so far

However, when I tried to connect dongle to pi, it showed

Few seconds later, it showed

When I ran Carplay.AppImage
It showed

After I plugged in the Dongle
It showed

The dongle I got is

Not sure what is happening

Could you offer some help?

Hi Ben,

Looks like yours is on the latest firmware version which seems to be causing issues with all of the apps that use this dongle. I need to try and look into the latest apk to find out whats been changed, if you want to try and downgrade, you can do that in the mean time. Obviously downgrading comes with the possibility of bricking!

I was having the exact same issue and was able to downgrade the firmware to 2022.12.08.
What I did was copy the .img file onto a FAT32 formatted USB stick and named the file “Auto_Box_Update.img”.
*Plugged the Carlinkit to an outlet
*insert the USB
*set timer for 5mins
*remove from outlet and remove USB stick
*React CarPlay working

here is the FW:

1 Like

It seems that the dongle can be connected to pi right now. However there is a transfer issue. Is this still related to the firmware?

Hi Ben, yes that is the firmware issue. I’d say either wait for the latest version which should resolve this, or give the downgrade a go

Thanks a lot for the file and clear instructions!

No prob! When are you releasing the new firmware?

@ygoz is currently dong some amazing work on the underlying package of node-carplay, once that’s merged I will build a new one!

@here @Rienus an early beta version is up, which should support the newer dongles, very early and rough version but if it could be tested and verified that would be great

Hey, I had today some time to try this new beta. It works very well. At least connecting to dongle. In earlier versions, sometimes I was having issues to connect at start off app. Now is very good.

What is more, application runs very smooth.

The main thing that I need in my configuration is keyboard working and keybinding.

So I’m looking forward on next betas. I can offer testing newer versions.

Good Job :+1:

1 Like

Awesome, thanks for testing, I can’t take any credit for this new one, @ygoz has done most of the hard work!

Keep your eyes open for future versions, should be on every couple of days until it’s out of beta


Dear great developer

I, like others, could not get a good connection.
Today I tested your v4 beta with CPC200-CCPA.
It did not work well and I would like to share the information.

$  ls -al
total 250652
drwxr-xr-x  4 pi pi      4096 Sep 29 22:11 .
drwxr-xr-x 21 pi pi      4096 Sep 24 10:04 ..
-rwxr-xr-x  1 pi pi 114885971 Sep 27 07:20 Carplay.AppImage
-rwxr-xr-x  1 pi pi 141762225 May 17 04:40 Carplay.AppImage.v3.0.2
drwxr-xr-x  7 pi pi      4096 Sep 17 15:49 react-carplay
drwx------  5 pi pi      4096 Sep 15 16:17 squashfs-root


 $ ./Carplay.AppImage
(node:3153) UnhandledPromiseRejectionWarning: TypeError: electron.systemPreferences.askForMediaAccess is not a function
    at createWindow (/tmp/.mount_CarplaPAoAyE/resources/app.asar/out/main/index.js:53:30)
    at /tmp/.mount_CarplaPAoAyE/resources/app.asar/out/main/index.js:76:3
(Use `react-carplay --trace-warnings ...` to show where the warning was created)
(node:3153) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see (rejection id: 1)
[3187:0929/] Exiting GPU process due to errors during initialization

A button labeled “Plug-In Carplay Dongle and Press” appears in the Electron window.
I connect the CPC200-CCPA to my iPhone (iOS 17.0.1) and click, but nothing happens.
It does not exit as it did in the previous 3.0.1 version.

Can you give some more information? Pi OS version, 64bit vs 32bit, and also do you have the udev rules in place?

Thanks for reply
I am using 64bit RaspberryPi OS
on RaspberryPi 4B

$ cat /etc/os-release
PRETTY_NAME="Debian GNU/Linux 11 (bullseye)"
NAME="Debian GNU/Linux"
VERSION="11 (bullseye)"
$ ls -al /etc/udev/rules.d/*.rules
-rw-r--r-- 1 root root   96 Sep 17 15:49 /etc/udev/rules.d/52-nodecarplay.rules
-rw-r--r-- 1 root root 1883 Feb 24  2022 /etc/udev/rules.d/99-com.rules
$ cat /etc/udev/rules.d/52-nodecarplay.rules
SUBSYSTEM=="usb", ATTR{idVendor}=="1314", ATTR{idProduct}=="152*", MODE="0660", GROUP="plugdev"

I hope this information is helpful

Thanks, one last thing, can you do an lsusb with the device plugged in?

Hi, beta 2 is available now, please give that a go, I think yours likely didn’t work because I forgot the add the newer dongle product IDs in.



Wow, I have to say, v4 first impressions are it is a massive improvement. Love the move to typescript and the folder structure is much more developer friendly. Cannot wait to jump in and hack away! great work guys.


I apologize for the delay in responding.
I am still using beta 1.
And this is the result of lsusb right after connecting the dongle.

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 1314:1521 Magic Communication Tec. Auto Box
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

After a while, this window appears on my machine.
スクリーンショット 2023-10-01 22.06.40
And soon this will happen.
スクリーンショット 2023-10-01 22.06.50
The lsusb at that time is as follows.

$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’ll try beta 2 later!

1 Like