Stuttering and eventually disconnects from carplay


I’m having some issues with V4 of React-Carplay. Overall the V4 is 10x better than V3 when it comes to sound quality and perfomance. However.

I’ve noticed that if there is an animation going on spotify or maps or both running at the same time. After som minutes it will start to stutter and then eventually disconnect CarPlay. If i’m on a screen that doesn’t have any animations going it works most of the time with no issues.

It did this on V3 also.

If i want to get going again i have to close the program and restart. Because it will not connect to bluetooth if i don’t restart.

I’ve also noticed that once i have it connected after a few seconds later says not connected on the bluetooth list. But it still works until it doesn’t again.

RPi 4B 4GB. No fans or heatsinks installed.
Standard 20fps

What about power consumption of all combined USB devices?

I let my Raspberry Pi run continuously. Only the HDMI output locks up, probably due to slight overheating. Via VNC, I can run the Pi and CarPlay all day. It stays stable even after regular pulling and connecting the iPhone connection cable.

If you use the wireless Carlinkit dongle, then the issue might be in your wifi environment.


Thats a good possibility that could be the case. But the Pi doesn’t complain about low power. I have this setup in my Volvo V70 2010. Also using the CarPiHat to have it shutdown safely after taking the key out of the slot.

I have 3 usb slots taken. screen power, touch and for bluetooth keyboard.
You don’t think that the bluetooth usb for the keyboard is doing anything to the dongle? This just came up from nowhere in my head right now xD

I do use the wireless dongle :slight_smile:

I would say that’s a high possibility, both Bluetooth and wifi are in the 2.4ghz range. I believe there is a setting to set wifi to 5ghz, but I suspect whether this does anything would be dependent on hardware

Next time the car is not frozen to death i’m gonna remove the keyboard usb thingy. Also gonna try it wired from the dongle to the phone.


Removing the bluethooth usb for the keyboard did not work. Using the CarPlay via USB doesn’t work. It tries to connect and it disconnect immeadiatly. I can hear the sound and it keeps doing this.

As long as i don’t have any animation going it’s fine.

This means i can’t use maps. i have to change song on my phone otherwise risking it disconnecting since it has animation on the specific screen.

This is hard to say it’s anything to do with the application itself, alot of people are using it without issue. At this point all I can suggest is poor power supply, slow sd card, upgrade dongle firmware (at own risk!) or lastly a faulty dongle

Where do you take power from with ur setup in the car when u didnt have the MostHat?

Have u considered having molex connectors on the MostHat for the car version?


I took the setup out of the car and plugged the Pi into a wall using Raspberry official power supply. It worked without issues or the heatsinks i installed did something good. If it still does this after i install it back into the car. The only thing left is that the Pi doesn’t get enough power.

Awesome, thanks for the update!

When I didn’t have a pimost I just used a cigarette light to usb plug, just made sure I got beefy one that supported USB-C, I am still running like that in the freelander 2 and have no issues

I take power from the harness to the CD Player. It might just be that the tappers i use isn’t good enough. If thats the case im gonna do an adapter harnerss since i hate to splice into wires if i dont really have to.

Do you use the carPiHat?


Haha, that’s pretty stupid, I’ll get that fixed!

Another update after som more testing. I’m starting to think it’s neither the power or that the board is getting to hot. It’s just loosing connection to the wifi. It’s not strong enought to go thru the dashboard or the Pi and the screen. I have it mounted behind the carPiHat.

I walked away when it was playing some music and it started to stutter exactly like it does in the car. It locks everything but the music keeps going with stutter until it dies completly.

I have some testing to do tomorrow to confirm :slight_smile:


I made an adapter harness. I almost started to think i did it. No. After maybe 10 minutes it started to stutter and then disconnecting. Got it going again and it did the same like 2 minutes later. I don’t even know anymore :frowning:

Should i try to redownload the autokit.apk again?

But that doesn’t make sense since it works great when i have Pi plugged into the wall.

Also wondering why it goes over wifi and not bluetooth only?
Reading on their website it says this on the dongle i use.
Bluetooth and wifi. For me it tells me that i can use whatever i like.
On my phone it’s using wifi. If i try to connect via bluetooth is connecting and then disconnecting immeadiatly.

Or IOS 17+ isnt support until i update the dongle?
But that also doesn’t make sense since it works when the Pi is plugged into the wall.

Update 20:32PM
I’m literally crying over confusion right now. Now it worked for like 30 minutes without problems. But this time i had the phone pretty close to the dongle.

So many questions :slight_smile:

I believe Bluetooth is only used to initiate the connection, once they have done a handshake it switches over to wifi.

Have you tried a firmware update on the dongle? It really is a last resort as comes with some risk, but I would say worth trying. Best route is to do it via an android device and an OTG cable

I got it to work now. I bought a USB extender. The dongle now sits between the gearselector and cupholder. The dashboard was to strong for the wifi signal to go thru.

1 Like