Is there camera support in the app?

When I start up the app, there is an extra icon that flashes up really quickly but then never comes back:

The one that looks like a camera shutter.

Does this mean there is some sort of camera support in the app? I’ve seen some canbus posts related to cameras, but I would like to use a pi camera, or if that can’t be done another generic usb camera.

Is this possible? Can anybody point me towards some exmaples/documentation?

Yeah it does have camera and microphone support, if you have a camera plugged into the pi, then when you go to settings, you get an extra drop down called cameras. You can pick your camera there, then the icon will be present. Currently it only supports auto camera display via can message (and that’s a very early rough implementation) however GPIO/keyboard support should be in the future

Thanks for the reply.

I have a camera attached to the pi (v3 noir wide angle) and i am able to activate it from python scripts, but I don’t see anything in the settings that allows me to choose a camera:

I see the camera icon in the app when it first starts for a fraction of a second, then it goes away

am i doing somethign stupid?..

If it detected a camera the drop down is next to microphone.

Does this website detect one?

Looking at this thread, it looks like you need to enable the driver

I just tried:
sudo modprobe bcm2835-v4l2

And it didn’t error, but it also didn’t make a difference.
I can’t see the camera through that webpage, it doesn’t have a camera drop down in the browser settings page, or in the react app.

I am slowly (re)learning working in the linux environmnt (it has been a number of years since i did) and some of what I say now may be absolute bobbins…

I did some googling, and found this page:

Which implies that the camera support has moved on from V4L2.

Incidentally, i have got the camera working on a python script using the picamera2 library. I tried using the libcamera mentioned in the previosu page, but got lost in the depths of installing a million dependancies.
I got it to pop up the camera feed on an input via the carpihat that I’m using.
SO the camera is physically installed correct, and does work. but obviously via a different mechanism.

I’m not sure what to do now… perhas wait until GPIO support is implimented as that’s how i plan to use it.

Hi Zoona,

I would try this gstreamer pipeline, copies the camera feed to a normal video device

gst-launch-1.0 libcamerasrc ! capsfilter caps=video/x-raw,width=800,height=600,format=NV12 ! v4l2convert ! v4l2sink device=/dev/video2

Originally I had the carplay video stream working like this and it worked well.