Error when opening Carplay.AppImage

I hope someone can help me with this:

When executing carplay.appimage i get this error. i already tried downgrading the carlinkit firmware to a earlier version from a recent forum post as well as even older versions i found on github. (I’m not sure the firmware downgrades where succesfull because i only got the red light on the dongle when trying to downgrade even when de usb drive was formatted to Fat32 and the .img file was named correctly. i tried multiple usb sticks)
The dongle is a CPC200-CCPA and the Pi is running Raspberry pi os 64 bit. without the dongle connected the caplay.appimage app starts up fine.

Is this still a firmware error?


i also get this error when i try repeatedly:


Hi, yes this looks to be the firmware problem. I’ll be make a new version using the latest node-CarPlay very soon which should resolve this.

ok thanks, is there a way to make this dongle work in the meantime? or is downgrading the firmware not possible with this one?