Embedding React Carplay into app launchers such as Open Dash

Hi I’m fairly new to using linux in general, however I have been messing around with both the React Carplay app and Open Dash for the last few weeks. Both are amazing and I can’t wait to implement them into my mk1 audi tt. However as I’ve seen done on this forum I want to use Open Dash as a front and run React Carplay in the app launcher. To be honest I’ve spent a good 8 or so hours trying to figure out what it even means to lanuch apps within another program, I learned a lot, but I still am lost on how I would even start imbedding any app into a program like Open Dash. I apologies if this is a slightly stupid question, but any help would be greatly appreciated.

It’s super easy, RsJudka did an awesome job of it. Get both apps set up so they both work as expected in standalone, then in open dash go to the external launcher page, there’s a setting icon IIRC, press that and it brings up a file browser, use this to locate the react-carplay appimage, click it, give it time to launch etc, and then job done.

Oh, well I thought it would be more complicated than that, that’s pretty amazing. However it still just crashes whenever I click the load button that I assume lets me pick the app to launch. I’ve seen on the issues for open dash one person had the same issue running his app with a 32 bit install of buster and he fixed it by purging and reinstalling pulseaudio however this did not work for me. I didn’t really expect it to because I’m running a 32 bit bullseye but it was worth a shot. I also am running a clean install as of tonight on a 3b+ where the only things I have are opendash, react carplay, and their dependencies. Any further help or ideas would be awesome.

I did a test of this the other day, it was a fresh install of dash and react-carplay on 64bit, no updates ran, just made sure I had the appropriate udev rules,

echo "SUBSYSTEM==\"usb\", ATTR{idVendor}==\"1314\", ATTR{idProduct}==\"152*\", MODE=\"0660\", GROUP=\"plugdev\"" | sudo tee $FILE

ran those, then configured it and it worked off the bat. It sounds ike you are hitting an issue more on the open dash side, so I’m not a great source of help on that one I’m afraid!

No problem, I was mostly asking because I had seen exactly what I wanted done on this forum with open dash and react carplay. I’ll check my udev rules and maybe try running 64bit or another distro or an x86 computer to see if anything changes. I’ll also see if the open dash slack can help me out, and I’ll post back if I find anything. Thanks